Jump to content


Photo

Need help with rails application


  • This topic is locked This topic is locked
4 replies to this topic

#1 sunil8627

sunil8627

    Newbie

  • Members
  • 2 posts

Posted 22 July 2010 - 07:49 AM

Hi,
I have just installed a rails application at http://thotjot.heliohost.org/ and my username is sunil862

I get a "We're sorry, but something went wrong." page whenever i go to the application.

This is what i see in the error log-
[Thu Jul 22 00:22:53 2010] [error] [client 121.247.154.191] File does not exist: /home/sunil862/public_html/404.shtml
[Thu Jul 22 00:22:53 2010] [error] [client 121.247.154.191] File does not exist: /home/sunil862/public_html/login
[Thu Jul 22 00:19:48 2010] [error] [client 121.247.154.191] File does not exist: /home/sunil862/public_html/404.shtml
[Thu Jul 22 00:19:48 2010] [error] [client 121.247.154.191] File does not exist: /home/sunil862/public_html/posts

Why is it looking for files under public_html? I have copied my app files under the rails_apps folder. Should it not look for the files there?

Thanks,
Sunil

#2 Byron

Byron

    Rank X Member

  • Root Admin
  • 6,931 posts
  • Gender:Male
  • Location:USA

Posted 22 July 2010 - 09:34 PM

This support request is being escalated to our root admin.

Heliohost Signup Monitor: http://bybyron.net/helio/sign-up.php


#3 Ashoat

Ashoat

    The Administrator

  • Root Admin
  • 6,868 posts
  • Gender:Male
  • Location:New York, USA

Posted 23 July 2010 - 12:13 AM

Hmm... isn't that a Mongrel error? Have you checked error_log folders around your directories (not the global one in cPanel)?

#4 sunil8627

sunil8627

    Newbie

  • Members
  • 2 posts

Posted 28 July 2010 - 12:25 PM

Hi djbob,
Sorry for the late reply.
Yes i think it is a mongrel error. this is what I see in mongrel.log-
** Starting Mongrel listening at 0.0.0.0:12468
** Starting Rails with production environment...
** Rails loaded.
** Loading any Rails specific GemPlugins
** Signals ready. TERM => stop. USR2 => restart. INT => stop (no restart).
** Rails signals registered. HUP => reload (without restart). It might not work well.
** Mongrel 1.1.5 available at 0.0.0.0:12468
** Writing PID file to log/mongrel.pid

Can you tell me what the problem is?
Thanks,
Sunil

#5 Ashoat

Ashoat

    The Administrator

  • Root Admin
  • 6,868 posts
  • Gender:Male
  • Location:New York, USA

Posted 29 July 2010 - 03:56 AM

Nope... there is no error there. That must mean your Ruby on Rails application is throwing an error, but not displaying it to the user. Two options:
1) Make it display errors to the user.
2) Find the private error_log somewhere in your user directory.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users