Jump to content


codename25

Member Since 18 Jul 2011
Offline Last Active Jan 18 2017 09:36 AM
-----

Posts I've Made

In Topic: Imagick Installation In The Server

17 January 2017 - 07:08 PM

 

vamdesign.tk/img2.png

Oh, I just assumed you wanted .png since your example was a .png.

 

 

 

Thank You for suggesting a solution. But even though, In Stevie, I used jpg format to convert image but still it was good. I don't know why jpg format is blotted in Tommy. 


In Topic: Imagick Installation In The Server

15 January 2017 - 06:53 AM

PHP Version:
http://krydos2.helio.../54/phpinfo.php

Input:
http://krydos2.helio.../pdf-sample.pdf

Code:

<?php

$myurl = "pdf-sample.pdf";
$image = new Imagick($myurl);
$image->setResolution(300, 300);
$image->setImageFormat("png");
$image->writeImage("pdf-sample.png");
Output:
http://krydos2.helio.../pdf-sample.png

I shrank the pdf a bit to make the image and it still looks pretty sharp to me.

 

 

 

The problem is converting to JPG is creating blotting. If converted to PNG it is OK.


In Topic: Imagick Installation In The Server

14 January 2017 - 09:21 AM

It will always show the primary version as 5.6. As long your domains are set to 5.4, the scripts on those domains should run under 5.4. It should take effect nearly instantly.

 

Hi,

     It's working fine now. But there is a problem, the converted image from pdf is blotted. I'll attach the image of both the original PDF(Img1) and the Converted image (Img2). Could you please suggest me any reason for this because in Stevie it was working fine.

 

This One is Original PDF

 

img1.png

 

 

 

This one is the Converted Image

 

img2.png


In Topic: Imagick Installation In The Server

12 January 2017 - 06:21 PM

 

Thank you for the reply,

 

I have changed all my domains to php54, But my server information is still showing php 5.6. Does it take time to initiate on my account? 


In Topic: Imagick Installation In The Server

12 January 2017 - 07:04 AM

 

This works for me:

<?php
$blob = file_get_contents("http://url-of-pdf.pdf");
$image = new imagick();
$image->readImageBlob($blob);
$image_count = $image->getNumberImages();
echo $image_count;
?>

 

Still showing the Error 500. I changed my code and used This code but it's not working too.

 

 

 

 

It should be working for PHP Version 5.4.45 on Tommy.

 

But my script is not working showing error 500

 

Also, aside from trying Byron's code, did you change the PHP version? Tommy uses 5.6 by default, which I don't believe has Imagick.

 

 

The PHP version is 5.6.24. I too doubt magick is not installed when I checked. How should i change it to 5.4?