Jump to content

Sending Confirmation Mail


Recommended Posts

i want to send email as user signup on my website . i use php code mail() function for this . but i dont know the settings of heliohost for that . plz help me

 

 

this is my php code :

 

if($status){
$to="$email";
$subject="[Together We] Activate your account";
$message="Hello $username !
Please, confirm your registration by clicking link .Link is valid only for 1 day.
Click to activate:
$from="From : Together We <no-reply@togetherwe.heliohost.org>";
$sentmail=mail($to,$subject,$message,$from);
}

 

 

 

 

I want to use my gmail account for sending and receiving emails because i dont know email properties of heliohost

Edited by deep958
Link to comment
Share on other sites

i used this site for my mail function . by checking status , its showing mail is send but i didnt receive any mail .

am i need to change some heliohost settings??



i got this error while sending mail

 

 

ECDHE-RSA-AES128-GCM-SHA256:128 CV=yes: SMTP error from remote mail server after end of data: 550-5.7.1 [64.62.211.131 11] Our system has detected that this message is\n550-5.7.1 not RFC 5322 compliant:\n550-5.7.1 'From' header is missing.\

Edited by deep958
Link to comment
Share on other sites

If you had read the link I posted there is an example of setting the from header:

<?php
$to = "somebody@example.com";
$subject = "My subject";
$txt = "Hello world!";
$headers = "From: webmaster@example.com" . "\r\n" .
"CC: somebodyelse@example.com";

mail($to,$subject,$txt,$headers);
Link to comment
Share on other sites

if($status){

$to="$email";

$subject="[Together We] Activate your account";

$message="Hello $username !

Please, confirm your registration by clicking link .Link is valid only for 1 day.

Click to activate:




$headers="From : togetherweindia@gmail.com";


$sentmail=mail($to,$subject,$message,$headers);

}
Link to comment
Share on other sites

In $headers, you r using heliohost mail account, but I want my Gmail account in that place also.
Thanks krydos, you r trying to solve my problem.

 

 

 

$to = "divyansh.agg15@gmail.com";
$subject = "[Together We] Activate your account";
$message = "Hello world!";
$headers = "From: deep958@togetherwe.heliohost.org\r\n";
$sentmail= mail($to,$subject,$message,$headers);

 

 

 

i used this code but still not working

Link to comment
Share on other sites

hurry!

now my code runs . previous code work now . i dont know why it was not working yesterday , but today its working .

Thank you krydos for helping me .

you always help me

 

but it goes into spam folder , do you know how to stop it from going into spam folder

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Content

    • By gomgo
      Hi! I want to use my e-mail (gomgo@gomgo.heliohost.us) to send and receive e-mail, how do i login in the e-mail. i use Windows, so use Windows Live Mail is my option, but is impossible, windows live mail is actuatually discontinued and impossible to use, so i can't use it, i tried to send me the instructions, but i don't receive anythingh, i tried to use the webmail with roundcube and horde, but i get 500 Error, so i want to use the e-mail, what can i do?
       
      Thanks
       
       
      Edit: I'm in the Johnny's Server
    • By ansab
      I have created a new email id on my account. First time it worked fie and opened in browser without any error. I have also setup the id on my android device using blue mail app. But for the last two days i am getting a error on opening the mail id using https://johnny.heliohost.org:2096/ it logs in to mail client and the shows the following error
      on this link https://johnny.heliohost.org:2096/xxxxxxxxxxxxxx/3rdparty/roundcube/index.php
      I can successfully send and receive mails using my device but not on web mail.
      I have deleted and recreated the account but the problem remains same.
      Ps: My other two mail id's are working fine.
      Please help.
    • By r0nmlt
      I had a problem my mail servers and thought this was solved but apparantly isn't.
       
      I have a static IP, but using the static IP or tommy.heliohost.org as mail server still give the same results.
       
      Anybody is using heliohost with pop/smtp settings?
       
      I can retreive mail on POP port 110 (unencrypted)
      Secure incoming mail port 995 is refusing connection outright
      even tried with putty and connection is terminated immediately
       
      on the smtp side
      port 25 and port 587 are open but are expecting an ssl connection to authenticate. "AUTH PLAIN" is not offered instead this is what is being offered:
       
      220-tommy.heliohost.org ESMTP Exim 4.92 #2 Sun, 13 Oct 2019 09:05:33 +0000
      220-We do not authorize the use of this system to transport unsolicited,
      220 and/or bulk e-mail.
       
      EHLO RonLaptop
       
      250-tommy.heliohost.org Hello RonLaptop [37.75.41.193]
      250-SIZE 52428800
      250-8BITMIME
      250-PIPELINING
      250-STARTTLS
      250 HELP
      421 tommy.heliohost.org lost input connection
       
      Trying via putty to use the AUTH command results in:
      "503 AUTH command used when not advertised"
       
      Using SSL on port 587 leads to:
       
      220-tommy.heliohost.org ESMTP Exim 4.92 #2 Sun, 13 Oct 2019 09:06:42 +0000
      220-We do not authorize the use of this system to transport unsolicited,
      220 and/or bulk e-mail.
       
      EHLO RonLaptop
       
      250-tommy.heliohost.org Hello RonLaptop [37.75.41.193]
      250-SIZE 52428800
      250-8BITMIME
      250-PIPELINING
      250-STARTTLS
      250 HELP
       
      STARTTLS
       
      220 TLS go ahead
      00000000  16 03 01 00 7E 01 00 00  7A 03 01 5D A2 E9 24 57   ....~... z..]..$W
      00000010  DF A7 48 4A 3D 8E 20 61  10 D6 30 76 69 DF A4 C6   ..HJ=. a ..0vi...
      00000020  29 E4 E8 F8 4A F8 A1 32  FA 1C A8 00 00 1C C0 14   )...J..2 ........
      00000030  C0 13 00 39 00 33 00 35  00 2F C0 0A C0 09 00 38   ...9.3.5 ./.....8
      00000040  00 32 00 0A 00 13 00 05  00 04 01 00 00 35 00 00   .2...... .....5..
      00000050  00 18 00 16 00 00 13 74  6F 6D 6D 79 2E 68 65 6C   .......t ommy.hel
      00000060  69 6F 68 6F 73 74 2E 6F  72 67 00 0A 00 06 00 04   iohost.o rg......
      00000070  00 17 00 18 00 0B 00 02  01 00 00 17 00 00 FF 01   ........ ........
      00000080  00 01 00                                           ...
       
      554 Security failure
      554 Security failure
      554 Security failure
       
       
      Trying to SMTP via port 465 which is the ssl port refuses connection outright.
       
      The settings being suggested on cpanel are:
       

       
      Any ideas why this is happening?
    • By roguitar
      Is php mail() function not working today?
      This is my base code:
      <!-- NO HTML CODE ABOVE --> <?php $email = "rogeriobsoares5@gmail.com"; $subject = "Email Test"; $message = "Hello, boy!"; mail($email, $subject, $message, "From: English U.P.<englishup19@gmail.com>\nX-Mailer: PHP/" . phpversion()); sentmessage = true; ?> <HTML charset="utf-8"> <HEAD> <TITLE>MAILER</TITLE> </HEAD> <BODY> <?php  if(isset($sentmessage)){ if($sentmessage == true){ echo "Message sent successfully!"; } } ?> </BODY> </HTML> I've been testing several times today, but I'm not receiving the messages at all. Why is that the case? Would anybody know the answer? Thank you!
       
      AN IMPORTANT PIECE OF INFORMATION: It's not working when I send to my gmail accounts, but only when I set $email as my Hotmail account. Why?
    • By zeonsel
      Hello.I add Domain netcore.icu.I add main account anton@netcore.icu.The website netcore.icu opens perfectly.I can send mail from anton@netcore.icu.But I can't get any mail, sended from  zeonkarusel@gmail.com.How to solve this problem?Thanks 
×
×
  • Create New...