Jump to content

[Solved] HTTPS on "default" subdomains - Ricky vs Tommy


awal1
 Share

Recommended Posts

Hello dear heliohosters :)

I've noticed a difference between Tommy and Ricky when it comes to the HTTPS version of the default subdomains,
namely: webmail.xxx, cpanel.xxx, and webdisk.xxx.heliohost.org.

1) On Ricky
http://cpanel.licool.heliohost.org loads the NOT secured cpanel login page.
https://cpanel.licool.heliohost.org loads correctly the SECURED cpanel login page. While,
2) On Tommy
http://cpanel.awal1.heliohost.org loads the NOT secured cpanel login page as well, but
https://cpanel.awal1.heliohost.org POINTS to the INDEX page in public_html! instead of loading the secured cpanel page.

Although Krydos has explained to me that on Tommy cpanel.xxx, webmail.xxx... etc are not real subdomains, they are actually proxies.
For instance, cpanel.xxx is a proxy to tommy.heliohost.org:2083.
I would like to know what is the difference then with Ricky that loads the right subdomain page weather using http or https? when Tommy doesn't

I hope my question is clear :) and thank you in advance for any help.

Edited by awal1
Link to comment
Share on other sites

Keep in mind that you're only allowed to have one account. Please delete any accounts in excess of one by going to http://www.heliohost.org/classic/support/scripts/delete

 

Going to cpanel. or webmail. your domain is not supported. Please log in to cpanel at https://www.heliohost.org/login/ and you can login to webmail at https://tommy.heliohost.org:2096/

Link to comment
Share on other sites

Thank you for the quick reply! :rolleyes:

 

Keep in mind that you're only allowed to have one account. Please delete any accounts in excess of one by going to http://www.heliohost.org/classic/support/scripts/delete

I have already deleted licool.heliohost.org, please notice that I am new to heliohost and was trying to get an account on Tommy after which I would eventually delete the previous account. My question is just about sharing the difference in behavior I noticed between Tommy and Ricky with the community, and I apologize for giving the impression of keeping two accounts.

 

Going to cpanel. or webmail. your domain is not supported.

You mean that it is not supported on Tommy with HTTPS? because with HTTP it is possible.
And in the case of Ricky I was able to log into webmail. and cpanel. my-domain with both HTTPS and HTTP.

Here are some screenshots of the what I get (notice the URLs in the browser's address bar):

 

1) on Ricky
https://imgur.com/vXGCryS HTTPS webmail login page

https://imgur.com/GQR4jTD HTTPS logged in webmail

 

2) on Tommy

https://imgur.com/3d5gCGy HTTP webmail login page

https://imgur.com/otGXWHh HTTP logged in webmail

https://imgur.com/Hi8ltyg HTTPS webmail URL pionting to index page instead of secure webmail

Edited by awal1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...