Jump to content


Photo

[HH#369320] have two problems...


  • Please log in to reply
6 replies to this topic

#1 HelioHost

HelioHost

    Announcements

  • Moderators
  • 4,923 posts
  • Gender:Not Telling

Posted 09 January 2019 - 08:59 PM

Username: astron, Server: Tommy, Main domain: astron.heliohost.org

*The first thing:*
*I got such a error message:*
Your PHP memory limit is set to 32 MB but should be set to 128M or more.
You should contact your hosting provider or system administrator to ask for
this to be changed.
-----------------------------------------------------------------------------------------------------------------------------------------------
*THe second problem:*
I'm interested for testing this chat system. It's really fully up to date,
but need some testing.
If I try to instal, I'll get this error message:
------
*Internal Server Error*
The server encountered an internal error or misconfiguration and was unable
to complete your request.Please contact the server administrator at
webmaster@astron.heliohost.org to inform them of the time this error
occurred, and the actions you performed just before this error.More
information about this error may be available in the server error
log.Additionally, a 500 Internal Server Error error was encountered while
trying to use an ErrorDocument to handle the request.
------
*This chatsystem is available here.*
https://justblab.com...-websocket-chat
*PS* I tried install to another server, had no problems.

If those problems can be solved I'll be very thankfull.
/* astron.heliohost.org */
This is an unmonitored account for announcements only.
Wiki | Facebook | Twitter
Posted ImagePosted ImagePosted Image
Posted ImagePosted ImagePosted Image

#2 Krydos

Krydos

    Rank X Member

  • Root Admin
  • 17,831 posts
  • Gender:Male

Posted 10 January 2019 - 01:34 AM

Which version of php are you using?

#3 neptunus

neptunus

    Newbie

  • Members
  • 4 posts

Posted 10 January 2019 - 10:48 AM



Which version of php are you using?

I use 7.0 and it is true that I have not tried to change and so do not know - maybe some other version is working.

But it is mandatory to use 7.0 or higher.

Really, some some things still works with 5.6, but all newer things needs for 7.0 or higher version.

 

The first problem is solved. If I turned up to  php 7.2 it began to work.   

Good!  Thanks for help!   

But the second problem is still live, so I can't test this chat...


Edited by neptunus, 10 January 2019 - 11:10 AM.


#4 Krydos

Krydos

    Rank X Member

  • Root Admin
  • 17,831 posts
  • Gender:Male

Posted 10 January 2019 - 07:47 PM

The most common cause of 500 errors on php files is permissions. Make sure your permissions are set to 644, not 664 or anything else.

#5 neptunus

neptunus

    Newbie

  • Members
  • 4 posts

Posted 10 January 2019 - 09:50 PM

I've already tried everything possible things, the result is still the same - Error 500.
Yes I know what is error 500, i have changed everything, even all permissions set to 777, nothing changed, even it didn't help.
Then I deleted all the files, waited for half a day, then reloaded/uploaded whole .zip package and then extrated it on the server, still the same result.
I can't think out, what is the reason. Obviously this is something very simple.

Edited by neptunus, 10 January 2019 - 09:58 PM.


#6 Krydos

Krydos

    Rank X Member

  • Root Admin
  • 17,831 posts
  • Gender:Male

Posted 10 January 2019 - 10:56 PM

777 permissions would for sure result in a 500 error. PHP files have to be 644. What is the url of the 500 error?

#7 neptunus

neptunus

    Newbie

  • Members
  • 4 posts

Posted 11 January 2019 - 11:55 PM

777 permissions would for sure result in a 500 error. PHP files have to be 644. What is the url of the 500 error?

https://www.astron.h...box/account.php

Thank You for good ideas and help. Now is everything OK. I found the problem and if short to say, it was related to the permissions which were not everywhere as should be. Error log helped. 
I think this problem is no solved and this topic can be closed.
Once again, great thanks!

 

I'll begin now with testing it. Maybe it can be used in future.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users