Jump to content


Photo

[Solved] Over 3 min for loading my index page


  • Please log in to reply
11 replies to this topic

#1 gioller

gioller

    Newbie

  • Members
  • 6 posts
  • Gender:Male
  • Location:Italy

Posted 12 January 2019 - 07:39 AM

I always waiting over 3 mins before can see my web page. If this is a normal loading time and does not depend on technical problems, you can cancel my account.

 



#2 wolstech

wolstech

    Rank X Member

  • Root Admin
  • 10,416 posts
  • Gender:Male
  • Location:Pennsylvania

Posted 12 January 2019 - 02:20 PM

You're on the wrong server if you're trying to run a production-grade website. Tommy is the server for production websites that need pages that always load and load quickly (in seconds).

 

The other two servers are significantly slower. Ricky can be very slow at times as you're seeing due to age (12 year old server) and crowding, and Johnny's uptime is terrible since he's an overloaded test server (not for production use).

 

Getting a free account on Tommy is nearly impossible due to demand and we generally require donations to get an account outside the free signup window, but if you want, I'd be happy to move your account and offer you a trial for 2 - 3 days before you donate to be sure he meets your needs. If you're not happy, we'll just cancel your account after that time instead. :) Would you like to try?


Please do not PM me for support. Posting on our forums lets all of us learn.
Do you play Minecraft? | Server Monitors | And the Dumbass of the Decade award goes to...


#3 gioller

gioller

    Newbie

  • Members
  • 6 posts
  • Gender:Male
  • Location:Italy

Posted 12 January 2019 - 04:16 PM

Yes,ok.Thanks for this offer.

#4 wolstech

wolstech

    Rank X Member

  • Root Admin
  • 10,416 posts
  • Gender:Male
  • Location:Pennsylvania

Posted 13 January 2019 - 02:08 PM

Alright, I've moved you to Tommy. Your trial is good until Wednesday Jan 16, 2019. Please let us know what you think by then. If you decide to donate, please do so and post the transaction ID here. If you decide not to, your account will be suspended at the end of your trial.

 

If you see a 404 error or suspended/queued page, please clear your browser cache and flush your OS DNS resolver cache.


Please do not PM me for support. Posting on our forums lets all of us learn.
Do you play Minecraft? | Server Monitors | And the Dumbass of the Decade award goes to...


#5 gioller

gioller

    Newbie

  • Members
  • 6 posts
  • Gender:Male
  • Location:Italy

Posted 13 January 2019 - 10:07 PM

I try now, and load time looks good. But I have this problems now:
- I can't enter to  SFTP. I try with FileZilla and WinSCP but connection goes to time out.

- in my test page I see Strict and Warning messages that are not good for a production site. But I can't modify php.ini to not display them

- in the test page there is a link to a page that results in error 404. It can not be a cache problem because it has never been loaded



#6 Krydos

Krydos

    Rank X Member

  • Root Admin
  • 18,094 posts
  • Gender:Male

Posted 13 January 2019 - 10:55 PM

- I can't enter to SFTP. I try with FileZilla and WinSCP but connection goes to time out.

You're most likely trying to connect to Ricky's IP or port still. Try these settings:
SFTP host: tommy.heliohost.org
SFTP port: 1342
SFTP protocol: SFTP
SFTP logon type: Normal
SFTP Username: gioller
SFTP password: <same as cpanel>

- in my test page I see Strict and Warning messages that are not good for a production site. But I can't modify php.ini to not display them

You don't need to edit php.ini to turn off errors. The best way to get rid of the errors is to edit your code so there are no longer any errors to report, but if you'd rather just hide them put
error_reporting(0);
at the top of your script.
 

- in the test page there is a link to a page that results in error 404. It can not be a cache problem because it has never been loaded

What is the url?

#7 gioller

gioller

    Newbie

  • Members
  • 6 posts
  • Gender:Male
  • Location:Italy

Posted 14 January 2019 - 01:12 AM

1, yes I change from ricky to tommy, but in the cpanel port for tommy is showed as 1312,
2. thanks. Plus I have correct errors
3. link is http://pangya.helioh...ns/emot_box.php
 



#8 wolstech

wolstech

    Rank X Member

  • Root Admin
  • 10,416 posts
  • Gender:Male
  • Location:Pennsylvania

Posted 14 January 2019 - 01:27 AM

1, yes I change from ricky to tommy, but in the cpanel port for tommy is showed as 1312,
2. thanks. Plus I have correct errors
3. link is http://pangya.helioh...ns/emot_box.php

Tommy port is definitely 1342. If it says 1312, it's a typo on our part. We also support vanilla unencrypted ("plain") FTP on port 21. Some users have better experiences using that instead. Just be aware it's insecure.

As for the 404 error, there's a ton of problems. First, your .htaccess file in public_html is preventing that from being accessible. Second, you forgot to change the file permissions. I've renamed the .htaccess in public_html to disable it and fixed the permissions on the emoticons folder and emot_box.php for you. :)

 

You need to change your PHP files to 644, and all folders inside of public_html need to be 755. Once you do that, your scripts should work. I would also recommend figuring out what's wrong with that .htaccess file.


Please do not PM me for support. Posting on our forums lets all of us learn.
Do you play Minecraft? | Server Monitors | And the Dumbass of the Decade award goes to...


#9 gioller

gioller

    Newbie

  • Members
  • 6 posts
  • Gender:Male
  • Location:Italy

Posted 14 January 2019 - 08:52 AM

For the FTP changing port to 1342 has solved.

I made the change on permissions and now work.

 

For the htaccess I do not know what does not work. If I remove it, everything works but PHP 5.6.38 is loaded on the server. But from cpanel I changed it in 7.2.

If I use the 7.2 and in htaccess I do not insert the code related to joomla the site is not accessible (all pages show internal error).

However, the problem was related to file permissions, I think.


Edited by gioller, 14 January 2019 - 08:52 AM.


#10 wolstech

wolstech

    Rank X Member

  • Root Admin
  • 10,416 posts
  • Gender:Male
  • Location:Pennsylvania

Posted 14 January 2019 - 05:54 PM

 

For the htaccess I do not know what does not work. If I remove it, everything works but PHP 5.6.38 is loaded on the server. But from cpanel I changed it in 7.2.

If I use the 7.2 and in htaccess I do not insert the code related to joomla the site is not accessible (all pages show internal error).

That's possible. When we troubleshoot internal server errors, the first thing we do is rename .htaccess files and check the file permissions. I did both at once and didn't check the two causes individually, so it's possible the htaccess file is not an issue at all. If it works with the Joomla code in it, then you're good. 


Please do not PM me for support. Posting on our forums lets all of us learn.
Do you play Minecraft? | Server Monitors | And the Dumbass of the Decade award goes to...


#11 gioller

gioller

    Newbie

  • Members
  • 6 posts
  • Gender:Male
  • Location:Italy

Posted 15 January 2019 - 04:45 PM

Thanks for support. I have made a donation. This is the ID of transaction via paypal: 19J91702T60952151



#12 wolstech

wolstech

    Rank X Member

  • Root Admin
  • 10,416 posts
  • Gender:Male
  • Location:Pennsylvania

Posted 15 January 2019 - 05:17 PM

Your trial is now a normal Tommy account and will no longer expire.

 

Please be sure to log into cPanel via https://tommy.heliohost.org:2083/ (with nothing after the slash) or https://heliohost.org/login/ at least once per month to avoid inactivity suspensions. As long as you do this, you can keep the account as long as you wish. If you forget to sign in, you can renew your account from the inactivity page, or let us know and we can renew it for you.

 

Thank you for the donation :) 


Please do not PM me for support. Posting on our forums lets all of us learn.
Do you play Minecraft? | Server Monitors | And the Dumbass of the Decade award goes to...





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users