Jump to content


Photo

Joomla and PHP version

Joomla PHP

  • Please log in to reply
1 reply to this topic

#1 jamieoz

jamieoz

    Newbie

  • Members
  • 2 posts
  • Gender:Male
  • Location:Australia
  • Interests:Linux, Raspberry Pi, Arduino, IOT

Posted 08 February 2019 - 12:23 AM

I have decided to use Joomla for my website / blog. After installing via Softaculous  I get the following error:

 

Error
We have detected that your server is using PHP 5.6.38 which is obsolete and no longer receives official security updates by its developers. The Joomla! Project recommends upgrading your site to PHP 7.1 or later which will receive security updates at least until 2019-12-01. Please ask your host to make PHP 7.1 or a later version the default version for your site. If your host is already PHP 7.1 ready please enable PHP 7.1 on your site's root and 'administrator' directories – typically you can do this yourself through a tool in your hosting control panel, but it's best to ask your host if you are unsure.

 

Is it possible to upgrade PHP to version 7.1?

If so, how do I go about doing this?

 

Regards

 

Jamie



#2 wolstech

wolstech

    Rank X Member

  • Root Admin
  • 9,706 posts
  • Gender:Male
  • Location:Pennsylvania

Posted 08 February 2019 - 01:02 AM

7.1 is already supported. There should be an option in cpanel under the Software section to change versions. It lets you specify a different version for each domain.

Please do not PM me for support. Posting on our forums lets all of us learn.

Do you play Minecraft? | Server Monitors | And the Dumbass of the Decade award goes to...





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users