Jump to content


Photo

My server is dead! (VPS user on Eddie)


  • Please log in to reply
27 replies to this topic

#16 sohamb03

sohamb03

    Rank V Member

  • Members
  • PipPipPipPipPip
  • 326 posts
  • Gender:Male
  • Location:India
  • Interests:Web Designing

Posted 11 August 2019 - 07:01 AM

He wants his email service to be fixed.

Sayan Bhattacharyya


#17 Amoss

Amoss

    Rank III Member

  • Members
  • PipPipPip
  • 141 posts

Posted 11 August 2019 - 07:39 AM

@Krydos,

 

I use gmail to send/receive emails from my domain. When checking the pop3/receive emails, I get an error: Server returned error "SSL error: Leaf certificate is expired". I tried to uncheck and re-check the ssl checkbox and a new certificate was issued but that didn't help, I keep getting the error.

 

Also, when sending an email to mail-tester, I get the following error (I know you already took care of it but something happened after the restart):

 

Reverse DNS lookup or reverse DNS resolution (rDNS) is the determination of a domain name that is associated with a given IP address.
Some companies such as AOL will reject any message sent from a server without rDNS, so you must ensure that you have one.
You cannot associate more than one domain name with a single IP address.

Your IP address 216.218.228.90 is associated with the domain mail.stockdiv.com.
Nevertheless your message appears to be sent from stockdiv.com.

You may want to publish a pointer (PTR type) DNS record with a value of stockdiv.com or use mail.stockdiv.com as hostname in your mail software

Here are the tested values for this check:

  • IP: 216.218.228.90
  • HELO: stockdiv.com
  • rDNS: mail.stockdiv.com

 

Thank you.



#18 Krydos

Krydos

    Rank X Member

  • Root Admin
  • 18,179 posts
  • Gender:Male

Posted 11 August 2019 - 08:58 AM

I just added krydos@stockdiv.com to my gmail and I can send and receive emails from your domain without any errors. Is it still not working for you? This issue has taken 13 minutes of my time so far.

#19 jenovaon

jenovaon

    Rank I Member

  • Members
  • Pip
  • 47 posts
  • Gender:Male
  • Location:Here
  • Interests:Elsword, Website, RPG Maker MV

Posted 11 August 2019 - 09:17 AM

I just added krydos@stockdiv.com to my gmail and I can send and receive emails from your domain without any errors. Is it still not working for you? This issue has taken 13 minutes of my time so far.


Get your shovels and start digging, because. I. Am. Dead.

Posted Image


#20 Amoss

Amoss

    Rank III Member

  • Members
  • PipPipPip
  • 141 posts

Posted 11 August 2019 - 09:30 AM

This is when checking for new email: Error fetching mail. Mail from this account has not been retrieved since Aug 9. The following problem is only with the pop3/receiving emails.

 

Mail fetch history for "support@stockdiv.com" Sun, Aug 11, 2019 at 12:25 PM SSL Security Error. [ Help ]
Server returned error "SSL error: Leaf certificate is expired"
Sun, Aug 11, 2019 at 12:23 PM SSL Security Error. [ Help ]
Server returned error "SSL error: Leaf certificate is expired"
Sun, Aug 11, 2019 at 12:22 PM SSL Security Error. [ Help ]
Server returned error "SSL error: Leaf certificate is expired"
Sun, Aug 11, 2019 at 12:12 PM SSL Security Error. [ Help ]
Server returned error "SSL error: Leaf certificate is expired"
Sun, Aug 11, 2019 at 11:44 AM SSL Security Error. [ Help ]
Server returned error "SSL error: Leaf certificate is expired"

 

This is when sending to mail-tester: https://www.mail-tes...com/test-yf20l: Your reverse DNS does not match with your sending domain. (not sure it is related to the above).

 

Notice that sending an email from gmail to gmail (using domain's email) is not a good check. Anyway, maybe emails arrive but I can't retrieve them because of the above error.


Edited by Amoss, 11 August 2019 - 12:29 PM.


#21 Amoss

Amoss

    Rank III Member

  • Members
  • PipPipPip
  • 141 posts

Posted 11 August 2019 - 12:42 PM

I unchecked the SSL checkbox and changed the port to 100 in adding-a-new-account window in gmail and it works.

It's definitely something with the SSL but not sure what because the ssl checker site seems to report that everything is ok


Edited by Amoss, 11 August 2019 - 12:54 PM.


#22 Krydos

Krydos

    Rank X Member

  • Root Admin
  • 18,179 posts
  • Gender:Male

Posted 12 August 2019 - 05:10 AM

This is when sending to mail-tester: https://www.mail-tes...com/test-yf20l: Your reverse DNS does not match with your sending domain. (not sure it is related to the above).

Try this, edit /etc/hosts and change the line that says
127.0.0.1 stockdiv.com
to
127.0.0.1 mail.stockdiv.com
This issue has now taken 18 minutes of my time.

#23 Amoss

Amoss

    Rank III Member

  • Members
  • PipPipPip
  • 141 posts

Posted 13 August 2019 - 02:50 PM

I can't edit the file /etc/hosts , I get a red caption saying that the file is unwritable. And now Gmail is not working with stockdiv also with non-ssl saying: Connection Error. Server returned error "Connection refused".

 

When I try to connect to vestacp, I get: NO LANGUAGE DEFINED and I can't log in.

 

On the net I saw it is related to disk quota problem and how to fix it but when I try to edit the relevant file, again I get the file is unwritable. Also, disk quota entry is already unlimited.

When executing df -h and df -i I see some 100% with some folders...

 

Thanks


Edited by Amoss, 13 August 2019 - 10:36 PM.


#24 Amoss

Amoss

    Rank III Member

  • Members
  • PipPipPip
  • 141 posts

Posted 13 August 2019 - 10:36 PM

Thanks Krydos, everything is back to normal


Edited by Amoss, 13 August 2019 - 10:42 PM.


#25 Krydos

Krydos

    Rank X Member

  • Root Admin
  • 18,179 posts
  • Gender:Male

Posted 13 August 2019 - 10:40 PM

Turns out your file system went read-only due to filesystem errors. I ran fsck for you to fix the errors, and rebooted the VPS. Everything seems to be working again. Let me know if anything is still behaving oddly. 49 mins.

#26 Amoss

Amoss

    Rank III Member

  • Members
  • PipPipPip
  • 141 posts

Posted 13 August 2019 - 10:48 PM

Everything looks good now, thanks. Gmail is still not happy with my domain but you can't win it all :-)

Thanks, much appreciated.



#27 Krydos

Krydos

    Rank X Member

  • Root Admin
  • 18,179 posts
  • Gender:Male

Posted 13 August 2019 - 10:52 PM

Try this, edit /etc/hosts and change the line that says

127.0.0.1 stockdiv.com
to
127.0.0.1 mail.stockdiv.com



#28 Amoss

Amoss

    Rank III Member

  • Members
  • PipPipPip
  • 141 posts

Posted 13 August 2019 - 11:25 PM

Changed and sent an email to gmail, no good, got a failure email.

Do I need to do something else in between updating hosts and sending an email?


Edited by Amoss, 13 August 2019 - 11:26 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users