Jump to content


Photo

PHP inheritance & .htaccess


  • Please log in to reply
9 replies to this topic

#1 ArminC

ArminC

    Rank I Member

  • Members
  • Pip
  • 11 posts
  • Gender:Male
  • Location:Romania

Posted 12 August 2019 - 08:42 AM

Hello! I got a new.. pack of questions  :wub:

 

1. The PHP version is, by default, 5.6. Can I change the System Default value or I am forced to change it per domain (as I did)?

 

2. The CPanel version could be updated by the user? Or this is up to the host management?

 

3. I saw that the page displayed an error (500) and I found out that the .htaccess was the problem. So, I can't use it? 

 

Thanks!


Edited by ArminC, 12 August 2019 - 08:46 AM.


#2 flazepe

flazepe

    Rank VII Member

  • Moderators
  • 506 posts
  • Gender:Male

Posted 12 August 2019 - 08:54 AM

1. You need to change it per domain or use the inherit option.
2. The latter.
3. You can use htaccess. Check for any syntax errors.

#3 ArminC

ArminC

    Rank I Member

  • Members
  • Pip
  • 11 posts
  • Gender:Male
  • Location:Romania

Posted 12 August 2019 - 09:11 AM

I think I got now that command. My website is in form of a directory listing (just for the main domain). When I tried to enter a random folder, since I tried to get into some folder, it displays an error. I never encountered this one..

 

Spoiler
 
Any idea?
 
Edit: I saw something about fileinfo function? I need to activate something?

Edited by ArminC, 12 August 2019 - 09:33 AM.


#4 flazepe

flazepe

    Rank VII Member

  • Moderators
  • 506 posts
  • Gender:Male

Posted 12 August 2019 - 09:28 AM

Try: Options -Indexes

Also, that's a PHP error. Check your code.

#5 ArminC

ArminC

    Rank I Member

  • Members
  • Pip
  • 11 posts
  • Gender:Male
  • Location:Romania

Posted 12 August 2019 - 09:32 AM

I tried right now on my older host with the same index.php. It works.

 

The code:

$fi = new finfo(FILEINFO_MIME_TYPE);

Edited by ArminC, 12 August 2019 - 09:34 AM.


#6 flazepe

flazepe

    Rank VII Member

  • Moderators
  • 506 posts
  • Gender:Male

Posted 12 August 2019 - 09:35 AM

Finfo? Perhaps that extension is not installed. A root admin need to install it for you.

This support request is being escalated to our root admin.

#7 ArminC

ArminC

    Rank I Member

  • Members
  • Pip
  • 11 posts
  • Gender:Male
  • Location:Romania

Posted 12 August 2019 - 09:36 AM

Yeah.. That is what I was thinking about.. So I need to contact somewhere? Or?

 

Thanks.


Edited by ArminC, 12 August 2019 - 09:37 AM.


#8 ArminC

ArminC

    Rank I Member

  • Members
  • Pip
  • 11 posts
  • Gender:Male
  • Location:Romania

Posted 12 August 2019 - 09:52 AM

Also, when I tried to install the firewall, I encountered this one: 

 

 The PHP Gettext extension is missing on your server.


Edited by ArminC, 12 August 2019 - 10:27 AM.


#9 Krydos

Krydos

    Rank X Member

  • Root Admin
  • 18,185 posts
  • Gender:Male

Posted 13 August 2019 - 09:43 PM

Please post the following information:
  • Your cPanel username
  • Your main domain
  • The server that you are on
  • The version of php that you're using


#10 ArminC

ArminC

    Rank I Member

  • Members
  • Pip
  • 11 posts
  • Gender:Male
  • Location:Romania

Posted 14 August 2019 - 07:59 AM

* armync

* arminc.ga

* Ricky

* ea-php72

 

I need a comaptibility with the firewall and current index.php. I'm not entire sure which 'extension' (in addition to the above) are needed.

Isn't possible to have a php extensions manager with the non-ricky features forced off?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users