Jump to content

[Solved] re-installing Perl Modules on Tommy


michelc
 Share

Recommended Posts

Dear SysAdmin,

 

I am putting back my cgi's on tommy, and noticed that there are missing Modules

so I went to https://tommy.heliohost.org:2083/cpsess2244074712/frontend/paper_lantern/module_installers/index.html?lang=perl

and try to install YAML::Syck module for instance

I have the following error:

```Testing connection speed...(using fast method)...Done Ping:1.00054121017456 (ticks) Testing connection speed to ftp.yzu.edu.tw using pureperl...(cached .. 4004.49 bytes/s)...Done Ping:1.00051999092102 (ticks) Testing connection speed to ftp.arnes.si using pureperl...(cached .. 3809.34 bytes/s)...Done Ping:1.00037431716919 (ticks) Testing connection speed to cpan.lnx.sk using pureperl...(cached .. 3664.60 bytes/s)...Done Ping:1.00043797492981 (ticks) Testing connection speed to ftp.carnet.hr using pureperl...(cached .. 3586.73 bytes/s)...Done Ping:1.00057315826416 (ticks) Testing connection speed to mirrors.nav.ro using pureperl...(cached .. 3539.96 bytes/s)...Done Five usable mirrors located Ping:1.00098657608032 (ticks) Testing connection speed to 208.109.109.239 using pureperl...(using cached speed)...Done Ping:1.00148677825928 (ticks) Testing connection speed to 159.253.142.50 using pureperl...(using cached speed)...Done Ping:1.00158524513245 (ticks) Testing connection speed to 67.222.0.10 using pureperl...(using cached speed)...Done Three usable fallback mirrors located Fetching http://ftp.yzu.edu.tw/CPAN/index.html (connected:0).......(request attempt 1/12)...Resolving ftp.yzu.edu.tw...(resolve attempt 1/65)...@140.138.144.169......receiving......request success......Done Mirror Check passed for ftp.yzu.edu.tw (/index.html) Checking C compiler....C compiler (/usr/bin/gcc) OK (cached Sat Oct 19 17:17:57 2019) Tuned C compiler not available because it is not enabled....Done

 

```

 

 

Do we have gcc set on Tommy for perl install, not sute what to thing because other module installed properly (??)
 

here are the list of the Perl Module I was using on Tommy :

 

Crypt::Random
Digest
Digest::JHash
Digest::MD5
Digest::MurmurHash
Digest::SHA
Digest::SHA1
Digest::SHA2

DNS
Encode::Base58::BigInt
FindBin
GD
JSON
LWP::UserAgent
Math::BigInt
Math::Prime::Util
Math::Random::Secure
MIME::Base64
Time::HiRes
Time::Local
YAML::Syck
 

 

 

Thanks

+michelc

Edited by michelc
Link to comment
Share on other sites

update: sorry I didn't see the complete message ... it states module is up to date so I think I am fine ...
```
Method: Using cpanminus YAML::Syck is up to date. (1.31)

```


I was confused with the "false positive" error message for the system installed module

you can "CLOSE" or "DELETE" this topic, thank you

Edited by michelc
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Content

    • By jax
      I have successfully completed the node.js tutorial. I am trying to deploy an express app, and after reading another expressJS ticket I also tried putting the app in a subdomain titled express.jax.heliohost.us.
       
      The app folder is at the path - home/jax/node/riddleAdventure.
       
      The app url is - express.jax.heliohost.us/riddleadventure. 
       
      The app has been registered using application manager.
       
      Dependencies have been ensured.
       
      Yet, the same express-related 'Cannot GET' error is displayed when I visit the url.
       
      Please advise, thanks very much!
       
      - Jax
       
       
       
       
       
       
       
    • By thexkey
      Hello, since ricky server has been down for quite some time, i decided to pay to move to Tommy, however due to something wrong on my end, paypal did not work so i ended up paying using Litecoin.
       
      here is the LTC transaction ID: 9809c3303f66df7d2f87e46a76f33e99ff8355343a1cdfd5cc14dbaeb1e87e91
       
    • By RichHackney
      Not sure if this is the right place to post this.
       
      I had my site hosted on Ricky, so I followed the instructions to get moved to Tommy. This is my email for my new account richhackney3@gmail.com.  My old account email was richchackney@gmail.com and the address was www.richhackney.heliohost.org. I verified my email through the link and chose Tommy and made a donation.  Transation ID - 3YN66085490988937 When I try to log in I get page saying I need to click the link to verify my email which is why I don't have a username. Please advise. Thanks,Rich.   Attachments area    
    • By gintokki
      Thank you very much in advance!

      username: gintokki
      website: https://gintokki.art
       
      Transaction ID: 481506415H9731015
      Paid 2 EUR (USD 2,25) via Paypal 
       
      Have a good day, and thank you for the hard work everyone is doing out here!
       
    • By TypoMustakes
      Hi!
       
      I recently recommended your service to a family member of mine, who now wishes to join you. They made a donation, the details of which are attached. I wish to request an invitation to Tommy in their name. Their email, which they want to use for their profile, is peter.miskolczi21@gmail.com
       
      Thanks in advance!

×
×
  • Create New...