Jump to content


Photo

Problem with Git setup

git

  • Please log in to reply
3 replies to this topic

#1 gerroo

gerroo

    Newbie

  • Members
  • 2 posts

Posted 20 July 2020 - 01:17 AM

Hey,

I would like to have continous integration on my web application such that when I push my code, it is deployed.

In order to do that I decided to create a git repository on cPanel.

I cannot see the URL for the repository.

Here's the tutorial I'd like to follow: 

The current status of the UI is attached.


Edited by gerroo, 20 July 2020 - 01:31 PM.


#2 Krydos

Krydos

    Rank X Member

  • Root Admin
  • 20,335 posts
  • Gender:Male

Posted 20 July 2020 - 02:25 AM

I guess we'll wait for the tutorial link?



#3 gerroo

gerroo

    Newbie

  • Members
  • 2 posts

Posted 20 July 2020 - 01:31 PM

Hey,

Sorry about that. I tried the link function of the editor and I couldn't get it to work :(

youtube.com/watch?v=18tXFctuqQ0

 

UI

Attached File  Annotation 2020-07-19 211645.png   165.88K   14 downloads


Edited by gerroo, 20 July 2020 - 01:34 PM.


#4 Computer Nerd Kev

Computer Nerd Kev

    Rank I Member

  • Members
  • Pip
  • 45 posts
  • Gender:Male
  • Location:Australia

Posted 26 July 2020 - 09:30 AM

The clone URL in the video is for SSH access and Heliohost accounts don't allow this (except on the VPS accounts).
 
There's a banner at the top of the CPanel Git config. page in my account that says:
 

Warning: Your system administrator must enable shell access to allow you to view clone URLs.

 
Git also supposably supports HTTP/S URLs, not that I fully understand how this works for uploading.
 
I tried it once by creating a git repo under ~/public_html/, but although I tried hard, I couldn't get it to work (I can't find my notes on this, so not sure what the exact errors were). The Git documentation is far from clear on how HTTP-hosted repos work (though I don't find it particularly clear about anything for that matter).







Also tagged with one or more of these keywords: git

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users