Jump to content


Photo

[Solved] Discord.py new error, requires library update

discord.py discord bot

  • Please log in to reply
1 reply to this topic

#1 gonzalo3

gonzalo3

    Newbie

  • Members
  • 5 posts

Posted 27 July 2020 - 07:12 PM

Hello, discord.py library started causing errors for everyone. It seems the only solution is to update library. I'm using Tommy server right now.

Relevant thread:

 

https://stackoverflo...expected-keywor

 

 

 

Discord pushed a new change that changes the overwrites object.

Just reinstall the latest version of Discord.py

python3 -m pip install -U discord.py

That's it.

 

 

 

Error:

(...)
TypeError: __new__() got an unexpected keyword argument 'deny_new'

 

 



#2 Krydos

Krydos

    Rank X Member

  • Root Admin
  • 20,361 posts
  • Gender:Male

Posted 28 July 2020 - 03:39 AM

Tommy's python 3.7 module discord.py-1.2.5 has been upgraded to discord.py-1.3.4. https://krydos.helio...in/modules37.py





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users