Jump to content


Photo

[Solved] how to install Python packages

python

  • Please log in to reply
7 replies to this topic

#1 gad1001

gad1001

    Newbie

  • Members
  • 5 posts

Posted 01 August 2020 - 06:59 PM

I'm sorry if this is a silly nooby question, i'm a total beginner on running Python on a web server.

I'd like to run a Python script that requires some packages (such as pymal, pytorch, torch, opencv, pycocotools and detectron2).

Is it possible to install them on the Python version installed on the server? How do i do that?

In my pc i would do pip install but there is no terminal here

 

Thanks in advance.

 

(B.T.W. I am using Rick if it changes)

 



#2 Luigi123

Luigi123

    Rank X Member

  • Moderators
  • 2,444 posts
  • Gender:Male
  • Location:Winnipeg, Manitoba, Canada

Posted 02 August 2020 - 12:21 AM

Our users doesn’t have grants to install the packages on their own and plus we don’t offer SSH Terminal on the shared host.

Our root admin Krydos can install those packages that you have it above and we just need the version you are using.
Posted ImagePosted ImagePosted Image
Posted ImagePosted ImagePosted Image

#3 gad1001

gad1001

    Newbie

  • Members
  • 5 posts

Posted 02 August 2020 - 01:01 AM

thanks :)

pyyaml==5.1

pycocotools>=2.0.1

opencv-python 4.3.0.36

torch 1.6

detectron2 -f \https://dl.fbaipubli...h1.6/index.html

 

 

thanks again



#4 sohamb03

sohamb03

    Rank X Member

  • Moderators
  • 1,195 posts
  • Gender:Male
  • Location:India

Posted 02 August 2020 - 09:17 AM

Escalating your request to our root admin Krydos.

#5 Krydos

Krydos

    Rank X Member

  • Root Admin
  • 20,335 posts
  • Gender:Male

Posted 02 August 2020 - 08:38 PM

we just need the version you are using.

Are you using python2.7 or python3.6?

#6 gad1001

gad1001

    Newbie

  • Members
  • 5 posts

Posted Yesterday, 08:06 AM

3.6



#7 Krydos

Krydos

    Rank X Member

  • Root Admin
  • 20,335 posts
  • Gender:Male

Posted Today, 02:09 AM

Pycocotools is not compatible with our free hosting, and torch is 750MB. While I was trying to install torch pip almost crashed the whole server because it was using so much memory. I think you need a vps https://www.heliohost.org/vps/



#8 gad1001

gad1001

    Newbie

  • Members
  • 5 posts

Posted Today, 08:34 AM

ok ty :)







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users