Jump to content

[Solved] Fixing VPS rDNS


maicol07
 Share

Recommended Posts

I'm really not sure why it's giving that error. That's exactly the same way I've set up dozens of reverse dns before and they all work. For example here is the reverse dns section from mail-tester.com on an email from Cody:

ce58279b680b10e461ce8cde21a84282.png

And you can see that reverse dns is set up exactly the same way:

 

# dig +noall +answer -x 64.71.153.4
4.153.71.64.in-addr.arpa. 1054  IN      CNAME   4.subnet0.153.71.64.in-addr.arpa.
4.subnet0.153.71.64.in-addr.arpa. 14400 IN PTR  maicol07.it.
 
# dig +noall +answer -x 65.19.143.5
5.143.19.65.in-addr.arpa. 58277 IN      CNAME   5.subnet0.143.19.65.in-addr.arpa.
5.subnet0.143.19.65.in-addr.arpa. 13757 IN PTR  cody.heliohost.org.
Link to comment
Share on other sites

Is it still giving the same error when you tested it again?

Yes

post-91778-0-94259700-1605898472_thumb.png

 

The strange thing is that every rDNS checker (online and from cmd) shows that is properly setup...

 

P.S.: I can't paste images directly in the message like you did because IPBoard says the image extension has been disabled

Edited by maicol07
Link to comment
Share on other sites

I contacted our isp to ask them if they see anything wrong on their end, and they double checked everything for me. They said their servers are properly configured, and so are ours. They said that it looks like that mail tester is caching old data. We either need to wait for the cache to expire on mail-tester.com or contact mail-tester support and ask them to restart their local caching dns server.

 

P.S.: I can't paste images directly in the message like you did because IPBoard says the image extension has been disabled

To embed an image directly in your post so it doesn't have to be clicked to be viewed host your image on your server or use an image hosting service like gyazo or imgur. Then link the image url using bbcode like this

[img=https://example.com/image.png]
Link to comment
Share on other sites

Ended up it was Cloudflare... so I ask you to do one last rDNS change to mail.maicol07.it since I would like to have cloudflare on maicol07.it, while it isn't needed on the first domain

Link to comment
Share on other sites

Thanks for letting us know what the issue was. There you go

 

# dig +noall +answer -x 64.71.153.4
4.153.71.64.in-addr.arpa. 86400 IN      CNAME   4.subnet0.153.71.64.in-addr.arpa.
4.subnet0.153.71.64.in-addr.arpa. 14400 IN PTR  mail.maicol07.it.
Link to comment
Share on other sites

  • 2 weeks later...

 

Thanks for letting us know what the issue was. There you go

# dig +noall +answer -x 64.71.153.4
4.153.71.64.in-addr.arpa. 86400 IN      CNAME   4.subnet0.153.71.64.in-addr.arpa.
4.subnet0.153.71.64.in-addr.arpa. 14400 IN PTR  mail.maicol07.it.

Works fine! Thank you!

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...