Jump to content


Photo

[Solved] Request to update discord.py package on ricky


  • This topic is locked This topic is locked
3 replies to this topic

#1 merni

merni

    Newbie

  • Members
  • 2 posts

Posted 18 November 2020 - 04:42 AM

Per http://krydos1.helio...in/modules36.py the current version of discord.py on ricky is 1.2.4.

 

However, versions below 1.3.4 have an issue (due to an update in Discord's API) which causes them to crash. Sources:

Link 1: https://stackoverflo...expected-keywor

Link 2: https://github.com/R....py/issues/5109

 

And, in any case, new versions have features that are required (again due to changes in Discord's API) for certain actions. (See: https://discordpy.re...new.html#v1-5-0)

 

So I'd like to request that discord.py on ricky be updated to 1.5 at the minimum (preferably 1.5.1). All versions are compatible with Python 3.5.3+ (See: https://discordpy.re...l#prerequisites)



#2 Jenova

Jenova

    Rank II Member

  • Moderators
  • 61 posts
  • Gender:Male
  • Location:Hawaii

Posted 18 November 2020 - 04:59 AM

This support request is being escalated to our root admins.

#3 Krydos

Krydos

    Rank X Member

  • Root Admin
  • 21,402 posts
  • Gender:Male

Posted 18 November 2020 - 05:20 AM

Discord.py on Ricky's python 3.6 has been updated to 1.5.1 https://krydos1.heli...in/modules36.py



#4 merni

merni

    Newbie

  • Members
  • 2 posts

Posted 18 November 2020 - 05:33 AM

Thanks for the quick solution!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users