Jump to content

[Solved] WinSCP Auth Error


NamelessRumia
 Share

Recommended Posts

I'm starting to get an "Authentication failed." error when I try to connect to my website via WinSCP.

I don't know if this has to do with the increase in storage space that I got from donating.

 

File protocol: SFTP

Host name: tommy.heliohost.org

Port: 1342

Link to comment
Share on other sites

It appears to be an issue with WinSCP.

 

Specifically, accounts that use password-based authentication don't seem to work in WinSCP: I could not get any of the Tommy accounts I have passwords for to log in successfully using a password on WinSCP (even root failed with the password, but it worked fine when I used my SSH key...). Those same accounts that failed in WinSCP work just fine with a password if I use Filezilla's SFTP.

Link to comment
Share on other sites

Have you updated winscp when this started happening, or is it the same version that used to work?

 

It was the same version that used to work. Due to the issue, I ended up upgrading WinSCP to 5.17.9, and still no success. I don't know what version I used to have, just that it used to work. That's why I assumed it was something on heliohost's end, not WinScp.

Edited by robev
Link to comment
Share on other sites

  • 2 weeks later...

Just tested it and can confirm that unchecking that option does fix the password auth on Tommy. Thanks for the fix! :)

 

Weird though...since Johnny works fine with it checked.

 

Also of note, if you use a certificate to sign into SFTP, you have to remove the cert file from the site entry entirely (blank the key file field) if you want to log into an account with a password in WinSCP (this is unlike other clients, where the client will simply ignore the cert if its not valid for the username provided).

Link to comment
Share on other sites

BTW, cPanel states and invalid port:

attachicon.giftommy_sftp.png

There is an interesting bug that I can't track down where if you created your account on Johnny where the SFTP port is 1373, and then have your account moved to Tommy where the SFTP port is 1342 that page still shows the Johnny port. If you create your account on Tommy it shows the correct 1342 port. I think to simplify things in the future, as it becomes easier for people to move their account between servers, is to just make all three servers use the same port.
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...