Jump to content


Photo

[Solved] Update Python Module 'discord.py' to 1.6.0


  • This topic is locked This topic is locked
3 replies to this topic

#1 alaister

alaister

    Newbie

  • Members
  • 5 posts
  • Gender:Male
  • Location:Hong Kong
  • Interests:Coding

Posted 23 February 2021 - 03:27 AM

Hello,

 

I am using the Tommy server. The discord.py version installed is 1.3.4, but the latest stable version is 1.6.0. According to https://pypi.org/project/discord.py, the Python version requirement is >=3.5.3. Tommy is running python 3.7, so discord.py can be updated without causing any problems. I cannot use the new Discord features with this old version, e.g. AttributeError: module 'discord' has no attribute 'AllowedMentions'. Please update it as it is outdated.

 

Thanks.



#2 Luigi123

Luigi123

    Rank X Member

  • Moderators
  • 2,737 posts
  • Gender:Male
  • Location:Winnipeg, Manitoba, Canada

Posted 23 February 2021 - 04:19 AM

After looking at some topics related to that, we can definitely try to upgrade to a latest version for you. Let’s see what Krydos has to say.

Escalating
Posted ImagePosted ImagePosted Image
Posted ImagePosted ImagePosted Image

#3 Krydos

Krydos

    Rank X Member

  • Root Admin
  • 21,905 posts
  • Gender:Male

Posted 24 February 2021 - 04:19 AM

There you go https://krydos.helio...in/modules37.py



#4 alaister

alaister

    Newbie

  • Members
  • 5 posts
  • Gender:Male
  • Location:Hong Kong
  • Interests:Coding

Posted 24 February 2021 - 04:22 AM

Thank you very much!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users