Jump to content

[HH#808731] I often get error 500


HelioHost
 Share

Recommended Posts

Username: N/A, Server: N/A, Main Domain: N/A

Hello Support.
I have installed a PHP script that works at
http://azwebdds.heliohost.org/TESTSERVER/PHP/mykanboard
This is a simple Kanban board on PHP 7 and SQLite.
It works but is weird.

Periodically and often, near in a ratio of 1 (200) to 10 (500), I get an
error 500:
*Maybe I need to adjust some settings in the hosting cPanel?*


> *Internal Server Error*The server encountered an internal error or
> misconfiguration and was unable to complete your request.
> Please contact the server administrator at
> webmaster@azwebdds.heliohost.org to inform them of the time this error
> occurred, and the actions you performed just before this error.
> More information about this error may be available in the server error log.
> Additionally, a 500 Internal Server Error error was encountered while
> trying to use an ErrorDocument to handle the request.


Thank you.
--
Regards,
Alex

Link to comment
Share on other sites

500 errors are fairly common on Johnny because he's an experimental server. This means that the server is only intended for experimenting. If you want a server with better uptime, and less errors we recommend switching to a production server like Ricky or Tommy.

Link to comment
Share on other sites

  • 3 weeks later...
On 6/25/2021 at 8:39 AM, Krydos said:

... we recommend switching to a production server like Ricky or Tommy.

Hello Support.
As you recommended I try to move to Ricky for PHP7|Python3 and MySQL|SQLite|PostgreSQL (Java and RoR I needn't).
I doing it by methodic on https://wiki.helionet.org/accounts/moving-your-account

I make backup and want to delete my account.
От the page https://www.heliohost.org/scripts/delete.php I enter my account login azwebdds@gmail.com and correct pass and press Delete Account button.
But I have ERROR like "We're sorry, but we either could not find that account in the database, or it is not listed as active. Please contact an administrator if you feel this message is in error." 
Thank you.

image.png.73048b07511b2770ff627f83c2e0aba5.png

Link to comment
Share on other sites

1 hour ago, azwebdds said:

Hello Support.
As you recommended I try to move to Ricky for PHP7|Python3 and MySQL|SQLite|PostgreSQL (Java and RoR I needn't).
I doing it by methodic on https://wiki.helionet.org/accounts/moving-your-account

I make backup and want to delete my account.
От the page https://www.heliohost.org/scripts/delete.php I enter my account login azwebdds@gmail.com and correct pass and press Delete Account button.
But I have ERROR like "We're sorry, but we either could not find that account in the database, or it is not listed as active. Please contact an administrator if you feel this message is in error." 
Thank you.

image.png.73048b07511b2770ff627f83c2e0aba5.png

Are you sure you put in the correct username and password?

Link to comment
Share on other sites

16 hours ago, Krydos said:

You have to type your username, not your email address into that delete script.

Thank you.
I have deleted old registration.
When I start new I see that Ricky is full and page tell me about Johnny again (but we told about moving to Ricky)
(Based on your selections I recommend you start on the Johnny server, but it is currently full. You will need to wait 4 hours and 32 minutes for signups to reopen.)
What I need to do next for move to Ricky?

Link to comment
Share on other sites

Sign up shortly after midnight UTC when signups reset. Here is how long Ricky signups were available for the last week to give you an idea of how quick you need to be.

2021-07-12 45 minutes 25 seconds
2021-07-11 2 hours 41 minutes
2021-07-10 47 minutes 39 seconds
2021-07-09 1 hour 3 minutes
2021-07-08 10 minutes 26 seconds
2021-07-07 1 hour 48 minutes
2021-07-06 1 minute 40 seconds

Link to comment
Share on other sites

18 hours ago, Krydos said:

Sign up shortly after midnight UTC when signups reset....

Thank you much, Ben. All done successful. 

Small "css-screen-trouble" I see on cPanel: the INFO-box move under MAIN-box. Usually it stay on right-top place (pict. in add).
(same was on Johnny, I wrote you about 25/04 in [HH#645674] and you was fixed it on Johnny cPanel).

Where is.jpg

It move to here.jpg

Link to comment
Share on other sites

Ok, thank you.
Now the cPanel view correct.

I just try to install the EspoCRM from cPanel-> Softaculous for testing.
The script check modules before installing and no-found imap module.
In php info (https://azwebdds.heliohost.us/TESTING/php-info.php) I see that module was compilated (--with-imap=shared,/opt/cpanel/ea-php73/root/usr' '--with-imap-ssl' ) but probable it not turned on (enable) in php.ini
Have we access to php.ini or can you turn on this module by yourself?
(I think the modules will be more because this CRM usually ask many).

Thank you.
Regards Alex.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...