Jump to content

[Solved] Mail (forwarding) not working anymore for any of my domains?


Recommended Posts

Hi all,

I've added a couple of Email adresses to my new domain (stampaner.nl) recently but I noticed they didn't work (autoforwarding).

Testing my existing mailadresses for the existing domains (stamphaus.nl and cj7limited.nl) I noticed that NONE of the existing mailadresses work anymore.

I don't get a bounce or anything but the test mails I've sent just don't come through.

I probably did something stupid ūüėȬ†but I can't find what and can't find any similar issue in the Forum. Any Ideas what could have caused this?

 

Thnx again!

Link to comment
Share on other sites

I don't see any SPF or DKIM records, so I'd bet the mail is being discarded as spam. Without SPF or DKIM setup, most mail providers will reject your mail as spam, Google and Microsoft are especially sensitive to this and will not deliver mail that doesn't pass at least one of these checks. Krydos has to fix it since you're using our DNS.

Also, since you're using forwarding, I'd bet the bounce email is going into either a mailbox on your hosting account, is bouncing back to an unmonitored or invalid mailbox like postmaster and is being discarded, or isn't being sent at all (for example, Google replies with a message about the SPF/DKIM issue above if it receives mail that fails both of the tests, but Microsoft just throws your mail out and doesn't tell you).

Link to comment
Share on other sites

Thanks @wolstech,

That might be the case for the new domain (info@stampaner.nl) but the mailaccounts info@cj7limited.nl and info@stamphaus.nl are existing and working mailaccounts that worked fine for years.

I've sent the testmails from Gmail indeed. Checked the Gmail spam folder but no mails there :-|.

I'll go check how to setup SPF or DKIM record.

Any other ideas how the existing account could have stopped working...?

Link to comment
Share on other sites

1 hour ago, tstamphaus said:

I've sent the testmails from Gmail indeed. Checked the Gmail spam folder but no mails there :-|.

SPF and DKIM affect the behavior of the recipient, not the sender. These being missing would cause an issue if you were forwarding to gmail, but sending from gmail shouldn't be an issue at all (though Gmail is quirky in that I've found it sometimes doesn't like you sending email to an address that just forwards back to gmail, even if the domain that forwards the mail is properly configured).

Link to comment
Share on other sites

12 hours ago, tstamphaus said:

(stampaner.nl) (stamphaus.nl and cj7limited.nl)

SPF:

https://mxtoolbox.com/SuperTool.aspx?action=spf%3astampaner.nl&run=toolpage
https://mxtoolbox.com/SuperTool.aspx?action=spf%3astampaner.nl&run=toolpage

https://mxtoolbox.com/SuperTool.aspx?action=spf%3astampaner.nl&run=toolpage

DKIM:
https://mxtoolbox.com/SuperTool.aspx?action=dkim%3astampaner.nl%3adefault&run=toolpage
https://mxtoolbox.com/SuperTool.aspx?action=dkim%3astamphaus.nl%3adefault&run=toolpage
https://mxtoolbox.com/SuperTool.aspx?action=dkim%3acj7limited.nl%3adefault&run=toolpage

SPF and DKIM have been set up for the 3 domains you listed. If they still aren't being delivered you can send an email to https://www.mail-tester.com/ and post the report here so we can fix any other issues there are. Please be aware that the full contents of the email and all headers will be visible in the report so don't include any private information in the email.

Link to comment
Share on other sites

Thnx @krydos.

Testing SPF and DKIM now at mail-tester seems fine.

Mails still don't arrive at any of the three domains.

I'm not sure how/what to test on mail-tester.com but I've sent the following email:
- from my Stampaner - Gmail account
- to all three domains AND to the testmail account at mail-tester

That results in the following report: https://www.mail-tester.com/test-kgdixbvib

I also tested it from another mailaccount not related to any of the domains but the result there is the same.

Does this give any insights?


 

Link to comment
Share on other sites

That mail server 209.85.214.182 is not our IP. You'll need to contact whoever controls that IP address and ask them for support. We can only help you with emails sent from our servers.

Link to comment
Share on other sites

That IP belongs to Google...the mail came from a gmail mailbox.

Google's spam filter hates mail that gets sent through a forwarder to itself (e.g. example@gmail->forwarder@cj7limited->example@gmail). If his forwarders point to a gmail address, he should try sending mail to his forwarder from a non-gmail source or a different gmail mailbox from the one that receives the forwarded mail.

Link to comment
Share on other sites

Ok, thnx. I'll see if I can get some help from Google.

One other thing I just noticed (didn't see it before...): my main account now has the remark '! The mail service is switched off' ... 
I can't find where to (re)activate this in Plesk... Can you help me with that one? Might be causing the trouble.

Thnx again!
 

Mailservice switched off.jpg

Link to comment
Share on other sites

You can enable or disable mail on any domain by going to Websites & Domains > [domain] > Mail tab > Mail Settings > Check the Activate mail service on this domain box > Click Ok. I went ahead and did this for you.

Link to comment
Share on other sites

Sorry, I've been away for a couple of days (and checking thiings on my Phone didn't work out that well¬†ūüėČ)

I've done some analysis and it seems that my existing mailaccounts are a bit better of than the new one but both still have issues.

To check things/rootcause I have disabled autoforwarding and enabled a mailbox for all three accounts and than tried a number of things.

  • send an email to info@... on all three domains.
    • WORKS. All three domains are receiving Email in the mailboxes sent from a Gmail account
  • reply on the mail received to the Gmail account
    • WORKS. replies from all three domains are received by the Gmail account
  • now I re-activated the autoforward but keeping the mailbox in place
    • ISSUE no mail received on the Gmail account mentioned in the autoforward ūüėě
    • Changing the autoforward mail adress to a mail-tester account has no effect...¬†https://www.mail-tester.com/test-2tmy7uvq1¬†(for the domain info@stamphaus.nl) is not receiving the auto forward mail either ?!?

So... it still seems there is something going wrong with the auto-forward function. Even if I change the receiving mailadres to a non-Gmail account (mail-test).
All other mailfunctionality (send, reply) is working fine...

Any new ideas? I don't know where to look for an issue like this.

 

Link to comment
Share on other sites

Here's why mail-tester refused your email

Aug  7 11:28:59 tommy2 postfix/smtp[58525]: 531E74023371: to=<test-2tmy7uvq1@srv1.mail-tester.com>, relay=reception.mail-tester.com[94.23.206.89]:25, delay=5.2, delays=0.16/0.04/2.2/2.8, dsn=5.7.1, status=bounced (host reception.mail-tester.com[94.23.206.89] said: 550 5.7.1 Don't add us as CC or BCC, we need to be added as TO ! (in reply to end of DATA command))

It looks like you didn't send the email directly to them, but instead added them as CC or BCC, but the fact that they responded means they did get the email so it seems mail forwarding is working.

Here's why gmail.com refused your forwarded email

Aug  7 11:29:00 tommy2 postfix/smtp[55121]: 75C164022967: to=<[removed]@gmail.com>, orig_to=<SRS0=gii1=YL=gmail.com=[removed]@stamphaus.nl>, relay=gmail-smtp-in.l.google.com[142.251.2.26]:25, delay=0.58, delays=0.02/0/0.26/0.29, dsn=5.7.1, status=bounced (host gmail-smtp-in.l.google.com[142.251.2.26] said: 550-5.7.1 [65.19.141.77      18] Our system has detected that this message is 550-5.7.1 likely suspicious due to the very low reputation of the sending IP 550-5.7.1 address. To best protect our users from spam, the message has been 550-5.7.1 blocked. Please visit 550 5.7.1  https://support.google.com/mail/answer/188131 for more information. c10-20020a170902d48a00b0016f9420a15asi6809556plg.168 - gsmtp (in reply to end of DATA command))

I recommend contacting google mail and requesting that they deliver emails from 65.19.141.77 to your inbox. In the meantime a workaround is you could forward to a non-gmail address.

Link to comment
Share on other sites

P.s. I added mail-tester in the forward rule box (second tab, field 'Forward incoming messages to the following email address') and that caused the replies. So aparently the forward rule doesn't use 'TO' but 'CC' or something that triggers mail-tester to block these automatically forwarded mails.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...