Jump to content

FTP error 550


garrigue
 Share

Recommended Posts

Hello,

 

We installed Moodle 3 with PLESK script, it ran perfectly and we tried to upgrade Moodle to the last version 4.0.4

When my colleague tries to upload files whith its own account, he is facing this 550 error

image.thumb.png.9362a41855856e686cff17dddcc12e60.png

Sorry, it's written in french...

 

Could you please help us ?

 

Thank you

 

Link to comment
Share on other sites

I see permission denied which makes me think maybe the FTP is uploading with a different username than the files and directories were created with. I logged in to check your permissions and ownership, but I see a Wordpress install on both of your web roots. Where is this Moodle install located? Have you tried uploading the files on your main garrigue account? The other option is you could change all of the ownership of the files to your sub ftp account.

Link to comment
Share on other sites

Hi Krydos,

Sorry for the confusion, indeed, since my first message, my colleague removed Moodle to install WP instead.
However, you are right, I ran the script to install Moodle 3 and I delegate to him the moodle UPGRADE. Even if he has full permissions, I didn't know that he will face that kind of 550 issue.
So if I understand well, the same user must run the script and do the upgrade even if both users has full permissions. So what the use of making other usernames with full permissions?

Best regards,

Julien

Link to comment
Share on other sites

You can probably change the permissions of everything to make it work for both users. 644 = read/write by owner, read by group, and read by other. Your colleague's account is going to count as other so if you set the file's permission to 666 he should be able to edit those files. Filezilla has an option to recursively change all file permissions with just a few clicks so that might be the best solution for you.  

8 hours ago, garrigue said:

So what the use of making other usernames with full permissions?

This isn't a Plesk issue, it's a Linux issue. Permissions like this have been in effect in Unix since like the 70s or so. It's a security feature to prevent other users on the same server from altering your files unless you want them to.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...