Jump to content

500 internal server error on my Plesk account


Recommended Posts

Have you checked Plesk's error logs page? (Websites and Domains > click on the domain name > under the Dev Tools header towards the left side of the page, there's a "Logs" link.) That will tell you what the cause of the error is. You might have a misconfigured .htaccess file.

Link to comment
Share on other sites

Hello. Ive checked the error logs. I am posting it below:

[core:alert] /home/cyclos.za.org/public_html/.htaccess: Options not allowed here

And here is my .htaccess:

<IfModule mod_rewrite.c>
    <IfModule mod_negotiation.c>
        Options -MultiViews -Indexes
    </IfModule>

    RewriteEngine On

    # Handle Authorization Header
    RewriteCond %{HTTP:Authorization} .
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    # Redirect Trailing Slashes If Not A Folder...
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_URI} (.+)/$
    RewriteRule ^ %1 [L,R=301]

    # Send Requests To Front Controller...
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^ index.php [L]
</IfModule>

 

Link to comment
Share on other sites

Hello. No even after removing that portion, the error is still there.

Hello. Ive checked the error logs. I am posting it below:

[core:alert] /home/cyclos.za.org/public_html/.htaccess: Options not allowed here

And here is my .htaccess:

<IfModule mod_rewrite.c>
    <IfModule mod_negotiation.c>
        Options -MultiViews -Indexes
    </IfModule>

    RewriteEngine On

    # Handle Authorization Header
    RewriteCond %{HTTP:Authorization} .
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    # Redirect Trailing Slashes If Not A Folder...
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_URI} (.+)/$
    RewriteRule ^ %1 [L,R=301]

    # Send Requests To Front Controller...
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^ index.php [L]
</IfModule>

 

Link to comment
Share on other sites

If you check Login > Plesk > Websites & Domains > cyclos.za.org > Logs you can see that your error after renaming your .htaccess file has changed.

mod_fcgid: stderr: Next Illuminate\\Database\\QueryException: SQLSTATE[HY000] [1045] Access denied for user 'forge'@'localhost' (using password: NO) (SQL: select * from `languages` where `code` = en limit 1) in /home/cyclos.za.org/public_html/vendor/laravel/framework/src/Illuminate/Database/Connecti

Your database user obviously isn't 'forge'@'localhost'. It has to start with tchesoen_ you can find the exact database user on the databases tab if you forgot the name that you chose when you created it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...