Jump to content


nox

Member Since 29 May 2018
Offline Last Active Oct 30 2019 04:05 PM
-----

Topics I've Started

[Solved] Deploying more than one WAR

29 October 2019 - 12:22 PM

Hello,

 

I am having troubles with the WAR deploying process on my Java-enabled account.

 

I can upload my WARs properly, and they show up in the available WARs to be deployed. But whenever I deploy a WAR, the currently deployed WAR gets undeployed and the new one gets deployed.

 

I know Tomcat7 allows multiple WARs deployed at the same time and I'm wondering why I can't do that from the cPanel interface.

 

Maybe I'm misunderstanding, but I haven't got it to work so far.

 

 

Thanks for your help.

 

nox


[Solved] Storage space lost following new Tommy account

10 October 2019 - 01:50 PM

Hello!

 

About a year ago, I donated for the Sparkie server on GoFundMe and had my Tommy disk space quota doubled as a result.

 

I just recreated my account on the new Tommy server but I don't see the upgraded quota anymore.

 

Username: nox

Transaction ID: 4065-1934-4930-5835

 

 

Thanks for your help and your wonderful service.

nox


[Solved] Java shows as Enabled, but JSP pages are not rendering

11 July 2019 - 03:14 AM

Hello,

 

I have Java enabled on my account, and it says I should be able to execute JSP pages under public_html.

 

I've created a test page to make sure of that, but it fails to render a very simple directive, which makes me think that Java is either not correctly installed on my account or Tomcat may have crashed.

 

Here's the test page I've created: https://nox.heliohos...angeos/test.jsp

 

It only contains this:

<% out.println("No worries."); %>

It should show the words No worries. without the tags, but I do see the tags when I navigate on the page.

 

 

Thanks for your help.


[Solved] WARs not visible after upload - Tommy

08 July 2019 - 12:21 PM

Good morning,

 

I recently asked for Java to be reinstated to my account (it was removed due to a Tomcat service problem, I believe).

 

Then, once I got back to cPanel > Java, I uploaded two WAR files to be deployed. I can see the files in the file manager, but the Java section does not see them.

 

The only option I have is the Upload WAR button. I can't deploy any of my WAR files.

 

DgGYKt3.png

 

---

 

 uAeGROG.png

 

I know war deployment can take a while, but I don't think it should be that long for the platform to initially see the files.

 

Thanks in advance for your help.