Jump to content


wolstech

Member Since 25 Oct 2009
Offline Last Active Today, 02:12 PM
*****

#162624 Secure connection failure

Posted by wolstech on Yesterday, 03:57 PM

@rajdis: That's high load. That was the same one I had the other day. I tried again a few minutes later and it worked fine.




#162514 Tommy Downtime

Posted by wolstech on 23 August 2019 - 11:52 AM

I've used OpenManage Server Admin in the past on ESXi. It's been a while though since I've last had to set it up. Does the job quite nicely when used alongside the Dell ESXi image. OMSA would work on Sparkie if Krydos wanted to set it up since he's a PowerEdge, but Eddie is HP hardware (DL360 G6).

 

The console commands for the tables in your last example are the only thing I've used recently.

 

Proper redundancy is nice (and when I do servers, I do exactly what you said when I can...RAID 10 with a spare), but historically we've preferred capacity over reliability for cost and ad revenue reasons. It was only recently when we got the NAS that we got our first hardware with a proper RAID (I forget what type, I didn't set it up). Sparkie I believe was supposed to be configured as a raid as well (I think 10 was the preference, but we may have gone with 5). 

 

More often than not though, when our servers fail it's not hardware anyway, it's software corruption. cPanel was never designed to handle what we do to it. It's rated for a few hundred accounts (I think they say 400 max) per server, with the occasional create or delete. We cram well over a thousand in there (Tommy had around 2k when he died of disk failure, Johnny currently has 1500 active accounts, 10k if you count archives), and we're adding and removing users daily. In fact, cP themselves has admitted to us that we're the most extreme use case they have. Their support is always both dumbfounded and impressed that we've managed to make it work whenever we contact them (granted we do modify some parts of cP quite a bit to make it work, most of it is stock), then surprised when we tell them we give the accounts away for free on top of it all (they've given us tons of discounts for this...we're basically free marketing for cP). If anything, credit here goes to cPanel for a product that's well built to the point where can easily exceed its rated specs, and Krydos for spending all the time making it work!




#162425 Maintenance Complete

Posted by wolstech on 22 August 2019 - 11:57 AM

If you're on Ricky or Johnny, you can log in now.

 

If you were on Tommy, you no longer have an account and should download your files: https://www.heliohost.org/backup/ Tommy users who donated for their accounts can request an invite for a Ricky account for the time being if they wish.




#162360 [Solved] Point JSP application to main domain

Posted by wolstech on 21 August 2019 - 06:04 PM

For JSP files, sohamb03 has the solution.

 

For WAR files, this configuration is not supported. You'd need to just put a redirect in the root folder to redirect into the (invisible) Hbitsinfo folder. A simple index.php file can do that. Place it in public_html, set permissions to 644, and it should work.

<?php
header("HTTP/1.1 301 Moved Permanently");
header("Location: /Hbitsinfo/");
die("Redirect failed");
?>



#162355 Secure connection failure

Posted by wolstech on 21 August 2019 - 05:07 PM

Johnny's got something wrong with cPanel. I get to the login screen fine, but logging in with valid credentials redirects me to an error:

Internal Server Error
500

No response from subprocess (cpanel (cpanel)): The subprocess reported error number 72,057,594,037,927,935 when it ended. The process dumped a core file.
cpsrvd Server at johnny.heliohost.org

I had to try 3 times before I could get in successfully. I'm guessing load related, but I'll let Krydos confirm that.




#162209 [Solved] Here we go again....

Posted by wolstech on 19 August 2019 - 09:05 PM

Closing since I brought this up in an email-related topic. https://www.helionet...view=getnewpost




#162208 Email not working, Outgoing/Incoming mails are not being delivered

Posted by wolstech on 19 August 2019 - 09:04 PM

Ricky has quite a few issues at the moment mostly due to overloading. I'm getting emails from my scripts, but I suspect I'm not getting all of them (I can't check because half of my stuff won't even run without multiple attempts due to 500 errors). The support email on the forum relies on Ricky as well, and that's broken too.

 

I can't even get account backups to work at the moment. If I request a full backup, it never actually makes the backup...




#161810 [Solved] Help please, I still have problems with DNS entry

Posted by wolstech on 16 August 2019 - 05:15 PM

Pretty much what sohamb03 said. It's not your account, the domain just won't clean up like it should, making it impossible for me to finish removing it so you can add it again.

 

Krydos might be able to clean it up manually.




#161712 [Solved] Server move request

Posted by wolstech on 15 August 2019 - 03:03 PM

The domains merajbd.com and meraj.xyz have been cleaned up.




#161622 Questions and Answers

Posted by wolstech on 14 August 2019 - 09:25 PM

@jenovaon: We can email it to you manually if it doesn't work. The reason you're supposed to not have the email address released is because we have to change the TLD to .old to release it. An email to (you)@domain.old will obviously get lost if (you)@domain.com is the real domain.


#161547 What's the fastest CMS for personal blogging?

Posted by wolstech on 14 August 2019 - 11:35 AM

Yeah Joomla. With just a theme and one or two extensions it runs very well on our servers and is also less prone to being attacked in my experience (not to say it can't be, but it has a better design and security architecture, and there's also just lower demand for Joomla malware, so you run across far fewer malicious extensions and exploits for it).




#161507 [Solved] Permenant mobile theme for forum.

Posted by wolstech on 14 August 2019 - 01:09 AM

For others who might read this, the most common cause of this is using the mobile view to send/reply to PMs. If you do that, you'll get stuck in the mobile view.




#161505 What's the fastest CMS for personal blogging?

Posted by wolstech on 14 August 2019 - 01:05 AM

 figured they're not really worth it for me, especially wordpress. That thing is heavy as ....

 

Couldn't have said it better myself  :P

 

WP is the program we love to hate around here. Slow, bloated, and also full of security holes. It's the leading cause for High Load suspensions too.




#161503 [Solved] Request to temporarly replace Tommy with Ricky

Posted by wolstech on 14 August 2019 - 12:51 AM

@flazepe: It can be the same if you edit the old account first. We usually just put .old on the end.

 

Just be aware, if you reuse the email address for someone, there's a chance they may not be able to download their backup when it become available without assistance from us. When we load the backup system, we copy the email addresses from the accounts table into it. If the email gets changed to example@gmail.old before that snapshot of the accounts and email addresses is made, the invalid address will be loaded into the system and their backup request email will never arrive...




#161502 [Solved] Email Support and News (Cpanel) not showing up

Posted by wolstech on 14 August 2019 - 12:47 AM

Moving. Krydos might be able to set this up to Ricky so we don't lose the support email.

> set type=mx
> heliohost.org
Server:  WRT1200AC
Address:  192.168.2.1

Non-authoritative answer:
heliohost.org   MX preference = 0, mail exchanger = tommy.heliohost.org

tommy.heliohost.org     internet address = 65.19.143.6
>